062 LCD not lighting.

Post Reply
mwm
Posts: 44
Joined: Fri Jun 24, 2016 2:35 pm

062 LCD not lighting.

Post by mwm »

This is the one I posted pictures of in the "Counterfeit 062" thread. The voltages are:

D3: 10.3
D7: 0.3 ***
Q1 Left: 0.05
Q1 Top: 9.47
Q1 Bot: 9.51
C17: 0 ****
Q2 Top: 0 ****
Q2 Bot: 9.5 ****
U2: 4.3 ****
U1: 8.25 *****
C25: 0.6
C22: 2.6
TP1(?): 2.71
TP3:2.91 ****
TP4: 9.49
TP5: 5.02
TP6: 0.3 *****
TP7: 9.42
LCD Pin 18: 5.01
19: 5.02
20: 0
3: 5.00

I've marekd the ones that are clearly wrong with some *****'s. Nothing significant in the number. But it looks like something is dead on the board.

However, as noted in the counterfeit thread, the LCD module has no "signal" markings on it, which the instructions call for. I assumed the pin numbers were what that was, but looking at pictures with pin labels, this may not be the case. So the LCD may be on the wrong set of pins.
jye1
Posts: 1228
Joined: Wed Feb 20, 2013 4:58 pm

Re: 062 LCD not lighting.

Post by jye1 »

Did you mean you didn't get the backlight on? The pin 19 and 20 of LCD are for backlight. You've got voltage on the correct. Please check any opens like trace broken. Otherwise the LCD was damaged inside. The backlight is simply an LED.
mwm
Posts: 44
Joined: Fri Jun 24, 2016 2:35 pm

Re: 062 LCD not lighting.

Post by mwm »

Correct, the backlight doesn't come on. I confirmed the voltages on pins 19 and 20, and checked for open traces from them. Everything seems fine. This LCD module has always struck me as suspect, as it's missing the markings the assembly instructions refer to. Any chance of getting a replacement for it?
Post Reply