Page 1 of 1

Data capture via CP2102 module stopped working

Posted: Sat Jun 13, 2020 10:17 am
by fr08
I added a CP2102 TTL module (this one: to my DSO Shell in order to be able to receive data on my PC. The TTL module is wired (ground, TX and RX) to J5 on the DSO.

I used my PC with Win 10 and Free Serial Port Monitor to try and capture data. I chose the correct COM port and the options to those specified in the DSO manual (baud rate 115200, data bits 8, parity None, stop bits 1). I left the flow control setting at "Hardware". I started logging, and then pressed the buttons on the scope to start sending data. A ran the logging for a couple of seconds, then I opened the file and everything seems fine (the file contained a section with info on the scope, followed by the y/t data). In other words, everything worked perfectly during this first test.

Then I unplugged the USB and shut off the scope, and a few minutes later I was going to do another measurement. However this time it would not transfer the proper data. Only a couple of bytes were received, and the text file only contains some gibberish like "ÿÿ". I tried again, same thing. Now I can't get it to work like it did in my first test. I only receive handful of strange characters, not real measurement data.

I've tried all the obvious stuff: unplug and replug the USB cable, restart the scope, restart the PC, mapping to a different COM port in Device manager, using a different USB port, using a different USB cable...

What could be the problem when it worked once but won't work again, without changing any settings?

Re: Data capture via CP2102 module stopped working

Posted: Sat Jun 13, 2020 2:12 pm
by fr08
OK, so a small update. Maybe this is useful, maybe not:

I read on this forum (in the LiPo mod thread) that some of the CP2102 modules sold on the web have a design fault that causes them to run at 4.3V instead of 3.3V as they should. So I checked mine and it turns out it's one of the bad ones, it was at 4.3V. The issue can be fixed by cutting a certain connection on the circuit board though.

Since my module worked perfectly the first time even when it was running at 4.3V, I didn't think this would be the cause of my issues. Anyway, of course I want the CP2102 module to operate at its intended voltage so I carefully cut the connection on the board to make it run on 3.3V (and I verified with my multimeter that it is now running at 3.3V).

Just to be sure I did another try at sending data with the module at the intended 3.3V, expecting no difference to how it was at 4.3V. However, the result wasn't the same. Now I receive more than a couple of bytes, a few hundreds of bytes in fact. However, everything in the result file is still just a mess of random strange characters.