Screen doesn't show anything, probably faulty product

Post Reply
sez
Posts: 4
Joined: Sun Jun 23, 2019 1:14 am

Screen doesn't show anything, probably faulty product

Post by sez »

Hello,

I bought DIY DSO 150 from Banggood almost 6 months ago and yesterday I found time to assembly it. As manual states, before soldering anything, I tried to plugin 9V power to see the screen but unfortunately screen doesn't show anything. I checked the D2 with multimeter and it shows 9V.

I'm newbie about electronics but I guess it's faulty product. How can I get replacement or correct this problem (if it's something that I can solve)?
sez
Posts: 4
Joined: Sun Jun 23, 2019 1:14 am

Re: Screen doesn't show anything, probably faulty product

Post by sez »

Today I received a response from Banggod and because more than 180 days passed, Banggood doesn't make any replacement/refund, unfortunately I didn't know that, if I did I would assembly it sooner. I wonder what will be the response from JYE Tech side.
jye1
Posts: 1226
Joined: Wed Feb 20, 2013 4:58 pm

Re: Screen doesn't show anything, probably faulty product

Post by jye1 »

Did the LCD light up? When power was applied did you see the LED on PCB blinked? Please also check the voltages at the points marked V+ and +3.3V.
sez
Posts: 4
Joined: Sun Jun 23, 2019 1:14 am

Re: Screen doesn't show anything, probably faulty product

Post by sez »

No, LCD did nothing. No light or anything. Also no LED is blinked.

About checking voltages, I'm not sure how to do it correctly, But whem I put props to (-) on D2 and +3.3V shows -0.25, D2(-) and V+ shows nothing, +3.3V and V+ shows nothing. Can you please tell me how to do it correctly and exact points?
sez
Posts: 4
Joined: Sun Jun 23, 2019 1:14 am

Re: Screen doesn't show anything, probably faulty product

Post by sez »

JYETech didn't care about this. Great customer service.
RayPooley
Posts: 7
Joined: Fri Jan 31, 2020 12:07 pm

Re: Screen doesn't show anything, probably faulty product

Post by RayPooley »

sez wrote:JYETech didn't care about this. Great customer service.
To be fair you can't really expect them to do much when you have had the product for 6 months and done nothing with it in that time. They have no idea where you have kept it in the meantime or how it has been handled. You say you are a novice. Ok. Can I suggest you put the board down on a rubber sheet or anything else non conductive before you plug the board in and test the screen? Maybe you are laying it on something that is shorting out the screen. One other comment is about the voltage readings that are given in Step 4 of the leaflet. You can only expect those to exist when you have completed the installation of all of the through hole components and the soldering is good. Bad joints will cause problems that you will have to correct. If you are not sure how to check voltage with a multimeter (assuming you own one) then you need to address that issue first before proceeding. If you don't own a multi then you can't proced without one. What is your soldering iron like by the way. Is it variable temperature?
Post Reply