DSO138 troubleshooting - No AV- (no trace)

Posts: 3
Joined: Tue Feb 06, 2018 1:34 pm

Re: DSO138 troubleshooting - No AV- (no trace)

Post by Tora »

WereCatf wrote:Could I ask for help getting my scope to work? The digital side of things is okay; the MCU boots up, the buttons work, the display draws the picture just as it should, and I updated the firmware via ST-Link to the latest version without an issue, but the analog side isn't working. I already tried even replacing Q2, but that didn't have any effect whatsoever.

The board is powered from a 9V battery (actual voltage of the battery is at 8.1V atm)
Here are the most important values I am getting via multimeter:
AV-: 0.662V
AV+: 4.95V
V+ : 7V

Step 1: 0.826V
Step 2: -1.445V
Step 3:
Q2 collector: 5.39V
Q1 base: 6.98V
Step 4: -- this is where things seem to go wrong
D1+: 0.598V
D1-: 1.277V (and rising slowly?!)
Step 5: 0.598V
Good question free bets enhanced odds :) :)
Have you found an answer? :?: :?:
Last edited by Tora on Tue Mar 05, 2019 11:33 am, edited 2 times in total.
Let's get dolphins game
Posts: 1
Joined: Sat Jan 06, 2018 4:04 am

Re: DSO138 troubleshooting - No AV- (no trace)

Post by cmjelectronica »

Hi, all voltages are correct, except AV- = -3.85v, V- = 4.7v. Replace L1, L2, C24, D1, Q1, U4. It still does not work, no LCD signal is shown
Posts: 8
Joined: Mon Jan 08, 2018 4:24 pm

This doesn't make sense.

Post by Hextejas »

My readings are:
V+ = 8.35
VC2 = 6.22
VB1 = 8,14

And the testing procedures say this:

Code: Select all

Step 3: Check voltage at Q2 collector (Vc2) and voltage at Q1 base (Vb1). Vc2 should be around 6.4V and Vb1 around 8.3V. 
My voltages are correct according to the above.

Code: Select all

3 ) Vb1 is very close to V+. This case indicates that the emitter-base junction of Q1 is likely shorted inside.
My voltages are incorrect according to the above. My V+ is 8.35 so, is Vb1 a problem ?

These are contradictory
Posts: 2
Joined: Sun Mar 11, 2018 3:43 am

Re: DSO138 troubleshooting - No AV- (no trace)

Post by klefenz »

I built the oscilloscope and there was no trace. Checking I found out that C24 was charged at like -30 V :shock: . Checked other components until I found that L1 had been damaged, apparently I bent it too hard and cut the wire inside. I removed the component and straightened its leads, this fixed it, I guess it push the wires into contact. Then I soldered new leads to it and installed it again. Works perfectly now.
Posts: 1
Joined: Tue Apr 03, 2018 11:59 pm

Re: DSO138 troubleshooting - No AV- (no trace)

Post by paulosgal »

please help me, for several days I am desperately trying to solve this problem and I am not succeeding.
1st problem - when I turn on the current the screen turns white, I need to press the reset button to start normally.
2nd problem - no trace

I checked all the welds, all the components and everything seems to be in place.

I followed all the described steps and only found bigger discrepancies in the D1 diode, I removed the components but they look good:

D2 +: 9.39v (Adjustable Power supply)
V +: 8.61v
+3.3: 3.2v
AV +: 4.84v
AV-: -4.9v
D1-: 0.13v
D1 +: 10.71v and sometimes 8.83v (without the screen);
V-: 10.68v and sometimes 8.79v (without the screen);
V1: 0v
V2: 1.62v
R40: 0.81v
OSC: 2.18v
R39: -1.37
R38: 8.40v

I put a video on youtube ( https://youtu.be/40TubDHXCrc ) showing everything working except the most important TRACE.

Posts: 1
Joined: Thu May 17, 2018 2:51 pm

Re: DSO138 troubleshooting - No AV- (no trace)

Post by frafel »

Hi. This is my situation:

I powered DS0138 (without still connecting the screen) with 9.3 volts and I see the LED flashing slowly only twice; then I find the following tensions:

V1: +0.87 volts
V2: +3.38 volts
AV-: -1.0 volts (and sometimes -0.2 volts)
AV+: +4.9 volts

After reading the post 1094 I check everything and in my case I have only this incorrect thing:

on the sides of D1 I have:

to the negative lead: -2,2 volts
to the positive lead: +0,07 volts

if I try with the connected screen; the LED remains off, the BOOT happens and I see the image on the screen with the squares, all the buttons work but I DO NOT SEE ANY TRACK either touching the red test lead or connecting it to the test signal.

what can it depend on?
Posts: 2
Joined: Wed May 15, 2019 8:07 am

Re: DSO138 troubleshooting - No AV- (no trace)

Post by hemflit »


Can you please give me some more advice with the AV- failure?

The step 4 from the original post (voltage at D1) is failing. The negative side of D1 is 0.36 V (fine) and the positive is -4.79 V.
I've checked Q1, L2, D1 and C24 insofar as they react to the multimeter the way I'd expect them to.

Following post 2585 ("disconnect L1 and see if you can get higher negative voltage at D1 anode") I disconnected L1 and got -25.2 V on the D1.

Then following post 2588 ("This means the negative voltage generating circuit is good. The low AV- was caused by overloading. From the schematic you can see AV- connects only to U2, R10, and C11. Please check these components, especially U2") I desoldered R10 and C11 and checked them outside the circuit - they're okay.

Now it seems I should check the U2.
What would be a reasonably straightforward way to check it?
Should I just take it out and put in a replacement?
(I've got a replacement ready - but I wanted to ask if there's a more straightforward thing I could do first.)

Thank you in advance!
Posts: 1
Joined: Tue Sep 29, 2020 2:13 am

Re: DSO138 troubleshooting - No AV- (no trace)

Post by Statue »

Just finished assembling my DSO138, and have no trace (I do see the display). When I run the test mode, I get the slow-blink. One of the problems I had assembling it is several of the resistors have color codes that don't make sense, and when I test them with a multitester, they are borderline out of tolerance. But that aside, very few voltages are correct. Going clockwise, starting at AV-: AV- is 0.65V, AV+ is 4.95V, +3.3V at the top is 3.3V, +5V at the top is 4.99V, right side of D1 is 0.6V, left side of R38 is 8.71V, top of D2 is 9.48V, V+ in upper-right corner is 8.7V, TP22 is 3.3V, right side of R38 is 8.7V, left side of R39 - can't get a steady reading long enough to tell the value, OSC - can't get a steady reading long enough to tell the value, bottom of R40 - can't get a reading long enough to tell value, V2 on bottom left - 1.28V, V1 on bottom left - 2.8V, TP25 - 190mV, top of L1 - 190mV. Any ideas where to start looking? At the top of the article, it indicates if you have near 0 voltage at if I recall, top of R40, that U1 might have a problem with pin 46. In my kit, U1 was pre-soldered. I examined/photographed pin 46 of U1 with a 200X microscope - soldering looks fine. But that step only indicates if all other voltages except AV- are good, which is not the case for me. Odds are, this problem is from either one open pin, or a bad resistor.
Post Reply