DSO112A serial interface docs?

Color oscilloscope with touch panel
mwm
Posts: 44
Joined: Fri Jun 24, 2016 2:35 pm

Re: DSO112A serial interface docs?

Post by mwm »

Before sending a "Connect" frame to start capturing data, I always send a "Set parameters" frame that updates the values on the scope to whatever the user has set them to in sigrok.

If the scope is set to 20ms originally, it works fine. Until I try to change the timebase to 50ms or larger. I don't get a confirmation back from the set parameters frame, but the timebase does change. So do other settings. My code sends a Disconnect frame after that failure (forcing the scope to be in the mode I think it's in if the confirmation got lost), and I don't get a confirmation from that either.

If the scope is set to 50ms originally, it doesn't send back the confirmation for the "Set parameters" frame, even if I change the timebase to 20ms in that frame. It doesn't change the timebase or other settings, so it may be losing the frame completely. And I get the same behavior for the Disconnect frame.

On the issue with glitches, I'm starting to think that's in the scope. After receiving a frame (always a large one at this point), it looks like I get back a NULL byte before the first sync, try the read again immediately, and there's a delay of .2 seconds before I get the 0xFE byte. I've still got some checking to do, but thought I'd mention it in case you get to the code before I do. I'll update here when I get the testing done.

Finally, an unrelated reqeust: any chance of getting the DSO062's "output trigger" option on the 112A? I'm wanting a second scope if I can get that feature, and it seems like the DSO068 doesn't have it, so adding it to the 112A would let me go with the 068, which I'd really rather have.
mwm
Posts: 44
Joined: Fri Jun 24, 2016 2:35 pm

Re: DSO112A serial interface docs?

Post by mwm »

Ok, here's the update. I'm pretty sure there's at least one bug in the DSO112A serial interface code that generates frame ID 0xC0 data type 0x32 (the frame that holds blocks of samples of capture datas).

The length in the frame appears to be short by one. The same code that deals correctly with every other frame type needs to read one extra byte after reading that frame, which isn't required for the others. But even after correcting for that, I get a glitch in the data after every frame:
Ramp.png
If there's one bug, I suspect there's another.

While I'm at it, the documentation for the "special command" frame is wrong. It gives the lenghth field as 6 bytes, but there are 7 bytes in the frame. It certainly works for me if I set it to 7.
mwm
Posts: 44
Joined: Fri Jun 24, 2016 2:35 pm

Re: DSO112A serial interface docs?

Post by mwm »

I think I've figured out the delay issue, but I'm not sure. Since the DSO is sending a frame, there should be a delay after each frame while it waits for the trigger for the next frame. But that delay is a bit longer than I'd expect. Possibly I just don't understand why it's as long as it is.
jye1
Posts: 1228
Joined: Wed Feb 20, 2013 4:58 pm

Re: DSO112A serial interface docs?

Post by jye1 »

Sorry I will get back to this topic a little later since I need a quite time to concentrate to it. I'm still on travelling.
mwm
Posts: 44
Joined: Fri Jun 24, 2016 2:35 pm

Re: DSO112A serial interface docs?

Post by mwm »

Any news on this? I can't really provide a pull request for the driver if there is no released software that works with it.
saviosaltamontes
Posts: 1
Joined: Wed Nov 23, 2016 2:11 pm

Re: DSO112A serial interface docs?

Post by saviosaltamontes »

can someone tell me what is the latest firmware for the DSO112A? Where is located? I looked at the JYE website they only mention first release of the firmware 113-11201-200.
stromfo
Posts: 4
Joined: Tue Mar 27, 2018 5:15 pm

Re: DSO112A serial interface docs?

Post by stromfo »

When I try to open the zip file with FW
C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: The archive is either in unknown format or damaged
C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: The archive is either in unknown format or damaged
C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: The archive is either in unknown format or damaged
stromfo
Posts: 4
Joined: Tue Mar 27, 2018 5:15 pm

Re: DSO112A serial interface docs?

Post by stromfo »

When I try to open the zip file with FW 113-11201-21 I got these errors:

C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: The archive is either in unknown format or damaged
C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: The archive is either in unknown format or damaged
C:\Users\Steinar\Downloads\113-11201-215.rar: Corrupt header is found
C:\Users\Steinar\Downloads\113-11201-215.rar: Main archive header is corrupt
C:\Users\Steinar\Downloads\113-11201-215.rar: The archive is either in unknown format or damaged

Can you try to upload it again?
jye1
Posts: 1228
Joined: Wed Feb 20, 2013 4:58 pm

Re: DSO112A serial interface docs?

Post by jye1 »

Please see the file attached.
113-11201-215.rar
(47.47 KiB) Downloaded 755 times
stromfo
Posts: 4
Joined: Tue Mar 27, 2018 5:15 pm

Re: DSO112A serial interface docs?

Post by stromfo »

That worked. Thanks :D
Post Reply